Save
Saving
  • L
    Lift

    Altizure Desktop is a desktop application for professional users of Altizure.
    altizure_deskop_download.jpg
    It can be freely downloaded from Altizure altizure.com/download, and installed on any of your desktop computers. It is cross-platform, running either on Windows PCs or Mac PCs. It goes also with a sample data Cheng Yu Tung Building to start.


    Overview

    With Altizure Desktop, you can manage efficiently your professional data, offline and online, locally on your desktop machines and remotely on the Altizure.com .

    Currently, it is de facto an offline 3D viewer!

    You can offline view and browse 3D models stored on your local computer. The local viewing is often much faster as there is no internet bandwidth restriction. This allows you to demonstrate your professional project to your clients, in a more convincing manner and even without any internet connection.

    The "Local" contains a list of projects stored in your local computer. You can use "Add to Local" to add any local projects into this list for viewing.

    The "Remote" lists all your projects on the Altizure cloud once logged-in, using your Altizure account, it is your "My Projects" at altizure. You can download any of downloadable projects. A Pro project is downloadable regardless of being private or public. The projects are synchronized between your local machine and Altizure.com.

    When downloading projects, you are "Synchroniz"-ing your Pro project in "Remote" between your local machine and the Altizure cloud. You can also redistribute the downloaded local projects to others, who can then add these projects to "Local" with "Add to Local" .

    Last but not least, it is intended that this desktop offline viewer could be customized for our professional partners and users. You may send the request to support@altizure.com if you are interested in developing customized desktop applications with your own logo embedded.


    How to synchronize your Pro projects with your desktop?

    login-sync.jpg

    1. Go to the "Remote" Tab.
    2. Login with your Altizure account.
    3. Find the Pro project you want to sync, and click the "sync" button. When the project is synchronized, the "sync" button will be marked up with a "tick".
    4. If the sync fails due to some network problem, please click the "sync" button again.

    What will be synchronized with the desktop?

    offline-annotation-measurement.jpg

    1. The 3D models.
    2. The measurements you have marked up in the Altizure studio.
    3. The annotations you have created in the setup page.

    What can I do with Altizure Desktop?

    1. Synchronize, and view your Pro projects offline.
    2. Take measurement in distances, areas, volumes, offline.
    3. Check GPS or local coordinate of the models, offline.
    4. Toggle the rendering mode in "textured shaded" / "flat shaded" / "wireframe", offline.

    As the projects need to be downloaded from Altizure, these powerful features are only for Pro projects.


    How to pack the synchronized data for backup or sharing?

    open-synced-zip.jpg

    1. Go to the "Remote" tab.
    2. Find the synchronized project, and click the "Open synced folder" button.
    3. Pack everything listed in the folder to a zip file.
    4. Now you can backup this zip file or deliver it to your clients. You can later unzip and load it into Altizure Desktop.

    How to add a packed synchronized data to Altizure Desktop?

    add-unzip-offline-data.jpg

    1. Download and install the Altizure Desktop if you have not done so.
    2. Unzip the packed data.
    3. Go to the "Local" tab.
    4. Click the "Add to Local" button, and choose the unzipped folder.
    5. The project will be listed in the "Local" tab for your quick access.

    Can Altizure Desktop reconstruct 3D from images?

    No. All 3D reconstruction is computed on altizure.com. Altizure Desktop helps you to manage your Pro projects on your computer, offline.


    posted in Altizure Website read more
  • L
    Lift

    You can download the raw 3D models in OBJ format. Besides, you can convert the OBJ files into other formats by using the Offline Format Converter in Altizure Desktop. Please find the tutorial for Format Converter here.

    The formats that you can convert the OBJ files into include PLY, OSGB, KML, DAE, STL, orthomap, etc. You can download the free sample assets of obj files, orthomap, elevation map (DSM) and Google Earth 3D model at the bottom of this page.


    Summary:

    • Can I download the assets in free projects?
    • There are a lot of OBJ files inside model.zip. Why is that? Which one is my model?
    • How do I determine which part of the model does each OBJ represent?
    • Then what about the files created by using the Merge function in Offline Format Converter?
    • How to view 3D models in OBJ format?
    • How to upload orthomap/dsm to Google Earth?
    • How to import 3D models into Google Earth?
    • The loading speed of KMZ file is very slow in Google Earth. Some tiles are even missing. What happened?
    • Why are my download assets different from the content described on this page?
    • Sample for downloadable assets

    Can I download the assets in free projects?

    No. However, you can convert a free project into a pro project and download the assets.


    There are a lot of OBJ files inside model.zip. Why is that? Which one is my model?

    Our 3D reconstruction engine is tuned to generate high quality 3D models from images. However, high quality also means huge data size and this put great pressure on lower end computers and devices when they need to handle one, for example, in transferring over internet, in editing the 3D models or in rendering and etc. To tackle the problem, we have employed a technique called level-of-detail (LOD) to systematically simplify and break down large 3D models into smaller pieces which we call tiles and organize them in a quadtree structure. This technique allows our engine to handle large scale 3D models more conveniently and offers you a greater flexibility in handling the models as you can choose a comfortable level-of-details model to work with according to your constraints and needs.

    Quadtree structure:
    Altizure_Downloadable_Asset_FAQ_EN.png
    Example:
    Altizure_Downloadable_Asset_FAQ_EN (1).png
    In conclusion, each OBJ file in model.zip represents a particular tile of your model at certain level-of-detail. You can get the complete model after you have loaded all the tiles at the same level together into your software.


    How do I determine which part of the model does each OBJ represent?

    Every OBJ file is named with 3 numbers. Take the file “tile_1_0_16.obj” as an example. The first number (i.e. 1) represents the level-of-detail (LOD). The smaller the number, the more simplified is the model. The second and third number (i.e. 0, 16) represent its x-y location in the model respectively.

    Example:
    Altizure_Downloadable_Asset_FAQ_EN (2).png
    Since the tiles are organized in quadtree structure, every step up in LOD will bring 4 times more number of tiles. Tile area will also shrink by 4 times and its length will shrink by half accordingly. Therefore, the step interval in second and third number will shrink by half as well. This process repeats until it reaches the highest LOD. By then each tile cannot be further broken down and we define its length as 1 unit.

    Take our sample data, HKUST_CYT_Building, as an example. This dataset has highest LOD at level 5. Therefore, it has 2^5 = 32 tiles in both x and y direction at LOD5 and as such we says the model has a size of 32 times 32 unit large.

    In LOD level 5, the most detail level is reached and each tile has a length of 1 unit. Therefore:
    tile_5_1_0.obj is right next to tile_5_0_0.obj. The x coordinate is jumped by 1 unit.
    tile_5_0_1.obj is right above tile_5_0_0.obj. The y coordinate is jumped by 1 unit.

    In LOD level 4, each tile has a length of 2 unit. Therefore:
    tile_4_2_0.obj is right next to tile_4_0_0.obj. The x coordinate is jumped by 2 unit.
    tile_4_0_2.obj is right above tile_5_0_0.obj. The y coordinate is jumped by 2 unit.

    In LOD level 3, each tile has a length of 4 unit. Therefore:
    tile_3_4_0.obj is right next to tile_3_0_0.obj. The x coordinate is jumped by 4 unit.
    tile_3_0_4.obj is right above tile_3_0_0.obj. The y coordinate is jumped by 4 unit.

    In LOD level 2, each tile has a length of 8 unit. Therefore:
    tile_2_8_0.obj is right next to tile_2_0_0.obj. The x coordinate is jumped by 8 unit.
    tile_2_0_8.obj is right above tile_2_0_0.obj. The y coordinate is jumped by 8 unit.

    In LOD level 1, each tile has a length of 16 unit. Therefore:
    tile_1_16_0.obj is right next to tile_1_0_0.obj. The x coordinate is jumped by 16 unit.
    tile_1_0_16.obj is right above tile_1_0_0.obj. The y coordinate is jumped by 16 unit.

    In LOD level 0, each tile has a length of 32 unit and is as large as the model.
    Therefore it has only one tile_0_0_0.obj file.


    Then what about the files created by using the Merge function in Offline Format Converter?

    You must first understand the quadtree structure and the OBJ file naming principle among model.zip before understanding the file generated by using the Merge function. If you set the block size as 32 (which is the default block size), the Format Converter will merely merge the OBJ files in model.zip for every 32 by 32 unit area, and then generate the merged OBJ files. You can roughly view them as a larger piece of tile. They still maintain LOD but no longer quadtree structure. The purpose of it is to offer users a more handy control over their models as they do not have to import a large number of fragmented pieces into software everytime.
    Altizure_Downloadable_Asset_FAQ_EN (3).png
    Altizure_Downloadable_Asset_FAQ_EN (3) (1).png
    Altizure_Downloadable_Asset_FAQ_EN (5).png


    How to view 3D models in OBJ format?

    Here is an incomplete list of both free and professional softwares that read OBJ file:

    Free:

    1. Autodesk FBX Review: Product Page

    Professional:

    Adob​​​​e Photoshop: Product Page
    Autodesk 3Ds Max: Product Page
    Autodesk Maya: Product Page
    Blender (opensource): Product Page
    Unity: Product Page


    How to upload orthomap/dsm to Google Earth?

    You can use this feature if you meet the following conditions:

    • the input images contain GPS information
    • the alignment of 3D reconstruction and GPS is successful.
      A step-by-step guide:
    1. Download Google Earth Pro here. Please download the pro version instead of the normal Google Earth. And Google Earth Pro is free at the moment.
    2. Convert your downloaded files to orthomap/dsm by using our Offline Converter in Altizure Desktop.
    3. Open Google Earth Pro.
    4. Go to File -> Import and select the downloaded tif files. Then the viewpoint will fly to the geographical location of your model. Choose scale to upload your orthomap on Google Earth Pro.

    How to import 3D models into Google Earth?

    You can use this feature if you meet the following conditions:

    • the input images contain GPS information
    • the alignment of 3D reconstruction and GPS is successful.

    Please obtain the DAE and KML files by using our Offline Converter in Altizure Desktop. To display your 3D model, you can directly upload these files to Google Earth.

    DAE files contain the geometry information of your models. By importing them, Google Earth will place your models in the current viewing location.

    KML files contain additional GPS information. By importing them, Google Earth will place your models according to its GPS location.

    To import them:

    Open Google Earth Pro.
    Go to File -> Open and select the downloaded DAE or KML files. In the following example, we imported the level_2_0_0.kml file.
    Screenshot from 2016-04-21 16_44_44.png
    You may notice that the models sometimes sink below the Google Earth terrain surface. This is due to the lack of altitude information in GPS. You can fix it by manually adjusting the altitude.

    To adjust altitude:

    1. Expand the imported KML files in the sidebar (in left-hand side)
    2. Right click on the model icon
    3. Select “Properties” and go to “Altitude” tab
    4. Adjust the altitude to your needs and confirm

    Screenshot from 2016-04-21 16_45_40.png
    At the moment, we only provide kml and dae output up to level 5 because Google Earth cannot load higher resolution models in one batch.


    The loading speed of KMZ file is very slow in Google Earth. Some tiles are even missing. What happened?

    KMZ is in fact a zipped format. Therefore Google Earth will have to unzip it on the fly tiles are loaded. We suggest unzipping the KMZ file like a normal .zip file before importing into Google Earth. After unzipping you can import the Project_LOD.kml file.


    Why are my download assets different from the content described on this page?

    We are constantly improving our engine and providing more and more downloadable assets. If your project is reconstructed in an early time, the download assets in your project may not be up-to-date. In this case, please contact us by clicking the report problem button on the overview pages. We will arrange a free update to you after confirming the problem.


    Sample

    Below are the sample downloadable assets from Cheng Yu Tung Building and some other file formats that can be generated by Converter. Please feel free to download and test these samples. If you have any question, please contact us in the forum or support@altizure.com.

    Online result:

    Downloadable Asset:

    posted in Altizure Website read more
  • L
    Lift

    Summary:

    • WebGL Support
    • How to enable WebGL in browser?
    • What browsers are supported?
    • Download Compatible Browsers
    • Troubleshooting

    WebGL Support

    Altizure.com platform uses WebGL to offer in-browser real-time displaying of 3D content.

    In some older versions of browsers, the WebGL was not supported, or it has not been enabled by default. You can check if your browser is compatible with WebGL at http://get.webgl.org/.

    The following browsers support WebGL:
    微信截图_20190808172652.png


    How to enable WebGL in browser?

    1. Safari, you can manually enable WebGL:

      Go to Safari → Preferences → Advanced and check Show Develop menu in menu bar.
      Go to Develop → Enable WebGL

    2. Chrome

      Type chrome://flags in the address bar.
      "Enable" the "Override software rendering list" as the following image.

    chrome-flags.png


    What browsers are supported?

    Altizure runs best on the latest version of:

    Altizure supports the current and previous official release of Chrome, Firefox and Safari.

    Altizure supports IE version 11 and above.

    Each time when a new version is released, we begin to support the latest two versions and stop supporting the previous ones.

    If you are experiencing compatibility issues with the site, please make sure you are using one of the supported browsers with the most recent version.

    💡 See http://www.whatismybrowser.com/ if you're not sure what browser and version you're using.


    Download Compatible Browsers

    Chrome Firefox
    Desktop Desktop
    Android Android

    Troubleshooting

    If you run into problems, make sure your graphics driver and browser are up-to-date. Or, if you prefer, you may install one of the other compatible browsers listed above.

    Please contact us at support@altizure.com if you have any queries, and remember to send us the hardware spec of your device and a WebGL report which is the screenshot of this page.

    posted in Altizure Website read more
  • L
    Lift

    Altizure Converter is designed to suit the specific needs of each customer. It offers high quality, superfast and free conversion service that allows customers to smoothly convert the files into many other formats they want (.osgb .dae .stl .kml .ply).

    • Supported Platforms
    • Where can I get the Converter?
    • What kind of files can Altizure Format Converter convert to?
    • Who should read this article?
    • Features of Altizure Converter
    • Input and Output Paths
    • Where to download the input OBJ files?
    • How to fix the missing or corrupted d3dcompiler_47.dll error when * installing Altizure Desktop on Windows 7?

    Supported Platforms:

    • Windows (64-bit)
    • macOS

    Where can I get the Converter?

    The Offline Converter is now available for Altizure Desktop (Windows 64-bit & macOS).
    converter.png


    Right now, Altizure users can use Offline Format Converter to convert .obj files into the following formats:

    • .ply

      PLY file is the abbreviation of Polygon File Format, which can store generic 3D model data. We use PLY format to store the point cloud (i.e. point coordinates, colors and normals) in the offline converter.

    • .osgb

      OSGB file is the abbreviation of Open Scene Gragh Binary, widely used by professionals in fields like photogrammetry and map surveying. It is a binary representation of the model with all textures contained within one standalone file.

    • .dae

      DAE file is also called COLLAborative Design Activity, a commonly-seen 3D file format. COLLADA is an XML-based schema that enables you to transfer data among 3D digital content creation tools.

    • .kml

      KML file is a 3D file format that includes geographic information, and can be loaded to Google Earth.

    • .stl

      STL files describe the surface geometry of a 3D object without any representation of color, texture or other common CAD model attributes. It is widely used for 3D printing or prototyping.


    Who should read this article?

    People who have specific needs of model format in their third party software for redevelopment. e.g. map surveying, animation or CAD.


    Features of Altizure Converter

    Type of Conversion: Full project
    A whole project/ a bunch of .obj files can be converted into:

    1. Select Type: OSGB
      full-osgb-4.png
      Input Path: The full path of the project folder that you want to convert. Normally, the input folder will be the folder that you unzip from “model.zip” downloaded from Altizure.

      Output Path: The full path of the folder to which you want to export files. This could be either an existing folder or a non-existing one that the software will then automatically create.

      Please notice: At the moment, Altizure Format Converter only supports the Input Path and Output Path in English. It would be better for users to name all the folders in English letters as well as numeric and special characters.

    2. Select Type: Orthomap
      full-ortho-4.png

    Maximum Resolution & Keep Original Resolution:

    These two options affect each other. Maximum Resolution means that the maximum resolution of the output map should never exceed the value (default = 16384). The reason for such constraint is that for extremely big projects, it’s impossible to store a large orthomap/DSM into just one file (like city-scale project). So here in this case, you have two choices:

    One is to lower the resolution of the orthomap/DSM so as to keep the file below the maximum resolution that you set. In another word, uncheck Keep Original Resolution and keep Maximum Resolution as default (or type in a desired value).

    The second is to Keep Original Resolution and the software will automatically cut the original orthomap/DSM into several small pieces, with each piece under the maximum limit.

    Why the maximum resolution is 16384 in default?

    Before we explain why we set the maximum resolution as 16384, you need to first understand the concept of LOD and tile.

    The image resolution for each tile is 512x512 pixels. As the OBJ file at LOD level 5 has 32 tiles on each side, we set the Maximum Resolution at 16384x16384 (because 512x32=16384). In this way, for the models at LOD level 5 or below, Altizure Converter can generate an orthomap in its original resolution.

    1. Select Type: Merge

      Merge simply means to merge a bunch of .obj files into one big .obj file.

      More on tile_X or tile_Y
      full-merge-4.png
      ppt-tile.png

    What is the biggest Block Size that I can set?

    After reading the article on tile_X and tile_Y, you may now understand, the OBJ files that Altizure generates are named as tile_I_x_y. The first number (i.e. I) represents the level-of-detail (LOD). The second and third number (i.e. x, y) represent its x-y location in the model respectively.

    At level I, the maximum number for x- and y-coordinates of each file should not exceed 2^(l+1). To explain it, let's take a Level-5 model as an example. For the files at LOD level 5, the x- and y-coordinates will not exceed 64 (i.e. 2^(5+1)=64). This means, if you want to merge all the OBJ files at level 5 into one OBJ, you can set the Block Size as 64, which is also the biggest Block Size that a computer can handle so far.

    Please notice: Because of the RAM limit, it's difficult for the Converter to merge the OBJ files at high LOD levels into just one document. So, normally, in order to evenly cut the merged model into several pieces, we would recommend the ideal Block Size to be the power of 2 (i.e. 2^).

    1. Select Type: KML
      full-kml-2.png

    Type of Conversion: Single OBJ file

    A single .obj file can be converted into:

    1. Select Type: OSGB
      single-osgb-4.png
      Input Path: The full path of the .obj file that you want to convert.

      Output Path: The full path of the folder to which you want to export files. This could be either an existing folder or a non-existing one that the software will then automatically create.

    2. Select Type: DAE
      single-dae-4.png

    3. Select Type: KML
      single-kml-5.png

    4. Select Type: STL
      single-stl-4.png

    5. Select Type: PLY
      single-ply-4.png


    Input and Output Paths

    If you want to convert a full OBJ project into other formats, you should select the input path of the folder where you put all your OBJ files. In this case, both the Input and output paths should end with a folder, instead of a file.

    Example: for Full > Orthomap

    The Input Path could be C:\Users\Altizure\Desktop\CYT model-2017

    The Output Path could be C:\Users\Altizure\Desktop\CYT-Ortho

    This means, CYT model-2017 is the input folder, while CYT-Ortho is the output folder.

    However, if you just want to convert a single OBJ file, you need to select the specific file that you want to convert in the Input Path. While for the Output Path, you can select an export folder and the computer will automatically generate the name of the export file.

    Example: for Single > DAE

    The Input Path could be C:\Users\Altizure\Desktop\CYT model-2017\tile_0_0_0_tex.obj

    The Output Path could be C:\Users\Altizure\Desktop\output.dae

    Here in this case, C:\Users\Altizure\Desktop is the folder path that you select, while output.dae is the default name of the export file that Altizure Desktop automatically generates. You can rename the export file if you want, e.g. you can change it to C:\Users\Altizure\Desktop\Sketchup-output-1.dae or anything else.


    Where to download the input OBJ files?

    Upgrade to pro (you need to buy some alticoins), then download <project name>_model.zip. (Sample download files)


    How to fix the missing or corrupted d3dcompiler_47.dll error when installing Altizure Desktop on Windows 7?

    Please download and install kb4019990 from this website.

    posted in Altizure Website read more
  • L
    Lift

    Summary:

    • 1.How to import Altizure DAE files into SketchUp?
    • 2.Can I obtain .dae files by using Full project OBJ files > kml?
    • 3.SketchUp rendering is painfully slow. How can I speed it up?
    • 4.How to import models with a high level-of-detail in SketchUp?

    To import a file into SketchUp, you need:

    1. Free Offline Format Converter in Altizure Desktop. Tutorial on Format Converter
    2. SketchUp Download
    3. Sample of the downloadable assets

    1. How to import Altizure DAE files into SketchUp?

    The 3D model available to download at altizure.com uses .obj filename extension. Please watch the short tutorial or follow the steps below and convert your 3D models into DAE format.

    Step 1: Merge the .obj files. Go to Altizure Desktop > Converter and select Full project obj files > merge.

    All the .obj tiles at the same level of textures will be merged into one file. Take the example of a model in LOD level 5. If you set the Block Size as the default number 32, you will export 5 .obj files with each representing a particular level of textures.

    Please notice: .jpg files are the textures of model. They must be in the same folder together with other files of different formats.

    Step 2: Choose the level of model that your computer can process. Go to Single obj file > dae, and convert the selected .obj model.

    Step 3: Open SketchUp. Click File > Import. In the pop-up window, locate and select the .dae file for import.

    Please remember to choose COLLADA Files (*.dae) in the Files of Type drop-down list on the bottom right corner of the dialog box.
    1-x-1.png
    Step 4: After loading the .dae file, you may find that the model is not displayed in high resolution. By default, SketchUp downgrades higher resolution image textures to a maximum of 1024 x 1024 pixels.

    If you want to turn off this feature, you can go to Window > Preferences > OpenGL in Windows system. Check the box Use maximum texture size and click OK. In this way, you are telling SketchUp not to downgrade your model to 1024 pixels. For macOS users, please find this option in Properties > OpenGL.

    Important! By unchecking this option, the size of your image textures will have a sharp increase, severely testing your graphics card and system memory. So, please be cautious about the texture size. You can keep it unchanged if you do not have a high-performance video card.
    Use-Max-Tex-Size.png
    Step 5: By defult, the edges of a model would be visible in SketchUp. To hide them, you can go to Style > Edit > Edge Settings on the right panel. Uncheck Edges and Profiles to hide the lines.
    SketchUp-withEdgeSetting.png


    2. Can I obtain .dae files by using Full project OBJ files > kml?

    In essence, this is okay because the output .kml folder includes the files in DAE format. (Below is a screenshot of the .kml folder.)

    However, the biggest disadvantage of this method is that there are too many .dae files in the kml. folder. Why? Because the input data includes numerous .obj tiles, which will all be converted into .dae if you adopt this method. And it's quite time-consuming to load all .dae data in SketchUp .
    kml-folder-small.png


    3. SketchUp rendering is painfully slow. How can I speed it up?

    The slow rendering might be due to the power limit of your Graphics Card. You can try to lower the resolution of textures. Through our tests, we find that NVIDIA GTX 980 can load models of LOD level 6 smoothly.


    4. How to import models with a high level-of-detail in SketchUp?

    The concept of LOD level or high-level textures

    In short, the whole process can be summarized as: Merge the OBJ files > Convert OBJ to DAE > Import
    7-Levels.png
    Step 1: Go to Altizure Desktop > Converter > Full obj project > merge.

    If you want to merge the tiles at level 6 or above, we recommend that the Block Size should be 64— which is the highest that a computer can support. To further explain it, we use a model of LOD level 7. As we have illustrated in another article, the model should have 128x128 tiles at level 7, i.e. 2^(6+1)=128. This means, there'll be 4 .obj files if you merge the tiles at level 7, i.e. (128x128)/(64x64)=4.
    64Merge-L7-long.png
    Step 2: Select Single obj file > dae. Please make sure that each .dae file you generate has a different name.

    Step 3: Import .dae into SketchUp. After testing, NVIDIA GTX 980 can load all the 4 .dae files (as shown below).
    4DAEs.png

    posted in Altizure Website read more
  • L
    Lift

    The QGIS is an open source free geographic information system software. We will guide you in generating a contour map in shapefile format from a DSM map by Altizure.

    1. Download the sample DSM file from the bottom of the page https://www.altizure.com/support/articles/download_assets
      tutorial_dsm_contour_1-1.png

    2. Download and install QGIS from http://www.qgis.org/en/site/

    3. Load the downloaded sample DSM file, “orthomap_dsm.tif”
      tutorial_dsm_contour_2-1.png

    4. From menu bar, select “Raster” → “Extraction” → “Contour”
      tutorial_dsm_contour_3-1.png

    5. Configure contour extraction setting. Output location, contour interval...etc
      tutorial_dsm_contour_4-1.png

    6. Done
      tutorial_dsm_contour_5-1.png

    posted in Altizure Website read more
  • L
    Lift

    Altizure.com is the cloud platform for turning drone photographs into true 3D models and 2D ortho maps. It gets you connected to photography, photogrammetry and drone amateurs and professionals.

    An user simply upload photographs captured from a drone to altizure.com, then will obtain a reconstructed 3D model and a 2D map from the cloud computation. The resulting 3D models are hosted by the website, and they can be shared online and/or are downloaded for off-line use.

    We are also providing the Altizure APP both in iOS and Android for automatic drone photo capturing.

    There are four main aspects of altizure.com:

    • Content publishing platforms
    • Cloud computation and management platform
    • 3D model management
    • User management

    Content publishing platform

    • Explore
      It contains all public projects, sorted and filtered by user-defined metrics. For example, a user can opt to view the most liked projects in this month. It also has a search bar. Each project item in the list shows a thumbnail, its author, and brief statistics of the project, such as the total number of views.
    • My favourites
      It contains all the public and unlisted projects that are liked by the user.
    • My projects
      It contains all the projects owned by the user.

    Cloud computation and management platform

    • Create project
      All users with an Altizure account can create projects, no matter they have passed UAV verification or not.

    • Project overview
      The project overview page is a dashboard of a single project, in which the project owner is able to view and manage inputs, outputs, and monitor the online reconstruction process. In particular, the owner can start / stop reconstruction, upload images, download outputs, report problems and change project settings such as project description and visibility.

    • Images
      It is a list of all images of the project for the owner to view and manage. The images include those that have been recognized by the machine to build the 3D model, and those that have been not.

    • Report
      It contains detailed technical report of the reconstruction process, such as camera estimation, GPS alignment and visibility map. It also shows a list of per-image results including number of tie points and reprojection error, which helps the owner to select better input images.

    • Points
      The points viewer visualizes the sparse point cloud and the camera poses. Users are able to deduce the flight path and the photographing pattern from the camera poses.

    • Orthomap
      The orthomap viewer allows the user to view the high-resolution 2D orthographic image with different levels of details.

    • 3D Models
      The basic model viewer is the place for users to view and interact with 3D models. Besides real-time viewing, users can socialize here by commenting on the project or by sharing to other social media platform.

    • Studio
      It is a model viewer with advanced functionalities for Pro projects, such as measuring distance between any two points, picking a point to get its real-world coordinate, and switching between different viewing modes to view model wireframes or geometries.

    • Project setup
      Or, as we normally call it, the "setting/setup mode". It is a model viewer where the owner can perform model-related settings, including recalculating GPS alignment, adding annotations and setting initial view point.

      How can I enter the setup mode?

      Go to My Projects →Select a project → Find Settings panel on the right side of page → In the Setup Model section, click the Setup button → Then, you’ll enter the setting mode of this project.
      1-x-1.png


    3D model management

    • Basic features
      The model viewer loads contents in real-time, displaying a coarse simplified layer first while gradually replacing it with more detailed layer as the loading continues. It provides basic controls like rotating, panning and zooming, which are supported both on desktops and on mobile platforms with multi-touch gestures.

    • Annotation
      The user can annotate on the model. An annotation is attached to a point on the 3D model, which moves when the model moves. Each annotation has its own symbol on the map, as well as a title and a description in which you can insert links and images.

    • Ruler
      If the model is already aligned to a real world coordinate frame, the user can get the distance of any two points on the 3D model by using the ruler tool.

    • Wireframe and geometry viewing mode
      The user can choose to view the 3D models in different mode like wireframe mode or geometry mode, besides the initial texture mapped model.


    User management

    • User profile
      This is the public profile page of a user, containing his/her public personal information, statistics of his/her cloud usage, as well as a list of all his/her public projects. The 3D model of the user’s most popular public project is also shown on the Profile page, and it can be seen by all visitors to this page. This enables a professional drone photographer and some other professionals to take this as their own portfolios.
    • Registration
      Here a new user can sign up with an email account.
    • Login
      Here a user can log into an existing account.
    • Forgot password
      Here, a user can reset his/her forgotten password and recover access to Altizure account.
    • User settings
      Here the user can perform a series of operations related to his own account. A user is able to set the profile picture, change the self description, reset password, and perform other account management actions. In addition, users can fill out UAV verification forms in this page.
    • Transaction history
      Transaction history records all the transactions that the user made, for example, the transactions on buying coins, paying for Professional Projects and getting refunds.
    • Notification history
      This page lists all the system notifications that the user has ever received.

    posted in Altizure Website read more
  • L
    Lift

    After registering, you will receive an activation email at the email address you entered during registration. Select the link in the email to activate your account.

    If you havnt received your activation email, the automated activation email message was caught by your spam filter.You can check your spam or junk mail folder for the email . If you still cannot find your email in the spam mail, you may visit https://www.altizure.com/settings to resend the activation email or contact us at support@altizure.com

    posted in Altizure Website read more
  • L
    Lift

    If the status of your reconstruction progress is “Pending”, it means your project is now waiting in a queue. Altizure has received your reconstruction command. However, all the machines are running tasks at the moment. Therefore, your project is put in a queue waiting for the reconstruction.

    It should be noted that our machines are available 24/7. The waiting time mainly depends on the number and the size of the projects waiting in front of you.

    If necessary, we would recommend you to upgrade your project and have a higher priority of the reconstruction.

    posted in Altizure Website read more
  • L
    Lift

    For both Free and Pro projects, a 3D reconstruction report will be generated after the project is finished. The report includes the data of reconstruction quality and effectiveness that may be helpful for users to better evaluate their projects.


    Where can I find the report?

    You can click the Report button on the left sidebar of the Overview Page.
    where-to-find-report-eng.png


    How can I understand the report?

    The report provides users with all kinds of data. Here in this article, we have listed several items that are particularly helpful for users who want to improve their 3D mapping skills.


    Global results

    In the following table, two figures need special attention. One is the Number of failed photos, i.e. those photos are ruled as invalid and are not used in reconstructing the model. The second is the Number of valid photos.
    global result.png
    Too many failed photos suggest a not-so-high-quality data capture, but 0 invalid photos do not mean a successful data capture. To evaluate the quality of a data collection, users must take into account many factors, including the following 6 pictures in SFM Result Visualization—probably the most useful section in this report.


    SFM Result Visualization

    Before moving on, we need to first understand the concept of keypoints. When users upload images of a certain object to Altizure’s cloud computing system, it will automatically detect thousands of keypoints on each image. If two keypoints on two different images are detected to be the same, they become correctly-matched keypoints. The computer will then extract the features of the object from a set of matched keypoints and generate a 3D model.

    The matched keypoints can only be detected on common areas (or overlapping areas) between different images. The larger the common area is, the more keypoints there are. The more matched keypoints are found, the more accurate the 3D model can be.

    Please also take a look at this article, which may help you better understand the concept of keypoint.

    Reprojection Error (Unit: Pixel)
    The 2D coordinates of correctly-matched keypoints that our system identifies on at least two different photos, will triangulate a 3D coordinate on the model. This 3D coordinate will then be reprojected back to each photo of those matched keypoints. The Reprojection Error is the distance between the reprojected position of the keypoint on a photo and the 2D coordinate of the same keypoint on the same photo.

    This figure visualizes the average reprojection errors in each camera/ photo. Each circle represents a camera or a photo. The colorbar on the right-hand side of the figure shows a certain type of color corresponds to a different degree of reprojection error. The redder the circle is, the bigger the reprojection error will be, and hence, the poorer the reconstruction quality can be.

    There may be several reasons causing the large reprojection error: repeated scenes (e.g. repeated patterns), blurry photos, or areas covered by weeds and woods, etc.
    reprojection-error.png
    Projection Distribution SD
    This figure visualizes the distribution of keypoints in each camera/ photo. Each circle represents a camera/ photo. The redder the circle is, the more unevenly distributed the keypoints are on that photo.

    The main reason for unevenly distributed keypoints is: the capturing area is not ideal for 3D reconstruction. This includes areas that are lack of patterns or textures, transparent objects or buildings with a reflective surface, etc.
    distribution-sd.png
    Rolling Shutter
    This figure visualizes the image quality of each camera/ photo. Each circle represents a camera/ photo. The redder the circle is, the poorer the image quality will be. For circles with a black edge, the image quality might be even worse, and more importantly, the poor quality of those images might severely affect the final reconstruction result.

    The influencing factors of image quality include: the flight speed of a drone when capturing data, focal length, light condition, etc.
    rolling-shutter.png
    Camera Pairs of XX% strongest connections
    In 3D reconstruction, only the matched keypoints are considered as valid. Therefore, the keypoints hereafter only refer to the matched keypoints.

    This figure visualizes the amount of keypoints on each photo and the connection intensity among cameras/ photos. Each circle represents a camera/ photo, while each line with a camera on each end implies that those two cameras are connected. The redder the circle is, the more keypoints the photo has, and hence, the stronger connection it has with other photos. XX% here means, the top XX% strongest connections are visualized in this figure.

    Overlap is the major influencing factor for the above two elements. You can take a look at this article for more information. If there are few image connections in certain parts of the mapping area, we would recommend users to increase the overlap in this area.
    camera-pairs-60percent.png
    camera-pairs-80percent.png
    camera-pairs-100percent.png


    Instant Orthomap

    During data capture, some objects that do not belong to the area that we are going to reconstruct will also be included in the photos. So, in 3D reconstruction, our system needs to identify the main area that we are going to reconstruct. This is where the Instant Orthomap comes in. It is a intermediate result generated after Structure-from-Motion. It will help the system to identify the reconstructed area.


    Visibility Map

    Our report shows the photo coverage of the reconstructed area. The whiter the better. If there's not enough photo in the reconstructed area, users need to add more images.


    Others

    In the Analysis Card

    Compute: Altizure will compute this parameter.

    Adjust: Altizure will optimize this parameter in 3D reconstruction.

    Keep: Altizure will not optimize this parameter in 3D reconstruction.

    Per-image Results Card

    Before: Before Global Optimization

    After: After Global Optimization

    Global Optimization: In this step, our system will minimize the total reprojection error.

    For Mean Reprojection error and Standard Deviation Reprojection error, the smaller the better. If the number still exceeds 2 after Global Optimization, it means the reconstruction quality is poor.

    posted in Altizure Website read more